IIS with Tomcat connector for AD integration

Post any questions regarding Installing or Upgrading Ebase, including problems starting up the Ebase Xi Server or Designer

Moderators: Dave, Jon, Steve, Ian

neilnewman
Ebase User
Posts: 183
Joined: Fri Dec 20, 2013 1:29 pm
Location: Dartford Borough Council
Contact:

IIS with Tomcat connector for AD integration

#1

Postby neilnewman » Thu May 03, 2018 2:32 pm

After a recent set of Windows updates to the server running IIS, the ISAPI connector stopped working that we use to enable AD integration.

I tried setting it up on a second machine just to check nothing had corrupted on the original server and hit the same error.

Do Microsoft still support ISAPI filters under IIS 8?
If they don't is there an alternative we can use and is there a set of instructions about, that covers the installation and configuration process.

https://support.microsoft.com/en-gb/hel ... pen-an-iis
0 x

Ian
Ebase Staff
Posts: 24
Joined: Wed Oct 10, 2007 9:40 am
Location: Ebase HQ
Contact:

Re: IIS with Tomcat connector for AD integration

#2

Postby Ian » Fri May 04, 2018 7:42 am

While I have not used the ISAPI redirector with IIS 8 (I have with IIS 7.5) it would seem that it can be done as can be seen in the following link:
[https://www.lisenet.com/2016/configure- ... erver-2012]

Please let me know how this turns out as if it does not work for you then I will install IIS 8 myself and get something working.

Regards

Ian
0 x

geadon
Ebase User
Posts: 57
Joined: Wed Aug 15, 2012 1:22 pm

Re: IIS with Tomcat connector for AD integration

#3

Postby geadon » Thu May 10, 2018 9:30 am

Hi neilnewman,

We use the BonCode AJP Connector for AD integration - http://www.boncode.net/boncode-connector. The ISAPI connector failed to work on v5 of Ebase for us so looked for an alternative and this one did the trick. Easy to install and configure on our MS Server 2012R2 with IIS8 and Tomcat 8.0.26.
0 x

neilnewman
Ebase User
Posts: 183
Joined: Fri Dec 20, 2013 1:29 pm
Location: Dartford Borough Council
Contact:

Re: IIS with Tomcat connector for AD integration

#4

Postby neilnewman » Thu May 10, 2018 9:44 am

Hi Geadon,
Many thanks for the information. I will take a look at this product, I was completly un-aware of it, but we are planning to upgrade our live Ebase installation to 5.3.2 in the near future.

I did manage to get the orginal Tomcat connector working with Ebase 5.2 after much digging around, I believe the issue was caused by a permissions problem which appears to of been introduced by a Windows security patch.
I used an icacls command to resolve the problem:
icacls "D:\Ebase\dbc-ebase-internal\UfsServer\tomcat\isapi" /grant "IIS APPPOOL\DefaultAppPool":(OI)(CI)M
at least its working until Microsoft throw another spanner in the works!

Many thanks
Neil
0 x

geadon
Ebase User
Posts: 57
Joined: Wed Aug 15, 2012 1:22 pm

Re: IIS with Tomcat connector for AD integration

#5

Postby geadon » Fri May 11, 2018 8:39 am

Handy to know that you did manage to get it working. The Boncode is worth a look at, seems simple and straight forward to configure. I'm literally upgrading one of our server to 5.3.2 now, I doubt there will be any issues with the AD integration but will let you know if we do come across any.
0 x


Who is online

Users browsing this forum: No registered users and 1 guest