Caching issue

Post any questions regarding Installing or Upgrading Ebase, including problems starting up the Ebase Xi Server or Designer

Moderators: Dave, Jon, Steve, Ian

Segi
Ebase User
Posts: 591
Joined: Mon Dec 09, 2013 6:37 pm

Caching issue

#1

Postby Segi » Mon Apr 09, 2018 6:24 pm

I have noticed a caching related issue a few times with Verj IO and wanted to see if anyone else is experiencing this issue on 5.3.2.

I made some modifications to one of my forms (which included an alert message being display on the screen) and deployed from my work station which is my dev environment to my production server.

When I reload the form, I am not seeing the alert messages that are supposed to be unconditionally displayed on the screen. The behavior almost seems to indicate as if Ebase is loading a cached copy of the form because it doesn't look like I am seeing the latest version of a form.

I tried the usual steps of clearing browser cache, trying private browsing mode in Firefox, trying a different browser but the problem still exists so I really think that this is something that is going on the server side and not on the client side.

I even went so far as to delete the project completely from the workspace in my servers' workstation and tried to load the page and sure enough it displayed the form when it should be telling me that the form doesn't exist because I deleted it from the server.

I haven't restarted my server yet but that shouldn't be the solution for this kind of issue anyways because you shouldn't need to restart the server every time you make changes to a project in order for the changes to go into effect.

I checked the server logs and don't see any errors in verjio-stdout or in localhost_access_log

Update: I just restarted Ebase and it is correctly loading the form now so whatever is causing this issue is being fixed by a server restart
0 x

Who is online

Users browsing this forum: No registered users and 2 guests