"Window must not be zero" when using Designer on Linux

Post any questions regarding Installing or Upgrading Ebase, including problems starting up the Ebase Xi Server or Designer

Moderators: Ian, Dave, jcoulson, Jon, Wai

User avatar
dvanhussel
Ebase User
Posts: 161
Joined: Fri Oct 19, 2007 12:45 pm
Location: Haarlem, the Netherlands

"Window must not be zero" when using Designer on Linux

#1

Postby dvanhussel » Wed May 15, 2019 8:40 am

Hi,

I run the designer on Linux (Ubuntu 19.04) which works fine when using a single monitor.
When multiple monitors are attached, the designer fails tor start with error "Window must not be zero".
It seems to be an issue in Java 10 and 11. But maybe you can implement this work around too?

https://github.com/lbalazscs/Pixelitor/issues/15

A temporary work around is to start the designer with one montor attached and the connect the second one. The designer then works on both screens as expected.

Regards,

David
0 x

Steve
Moderator
Moderator
Posts: 325
Joined: Fri Sep 07, 2007 3:44 pm
Location: Sandy, UK
Contact:

Re: "Window must not be zero" when using Designer on Linux

#2

Postby Steve » Wed May 15, 2019 9:14 am

Hi David,

We have seen this error before and it is a bug with Java 11.

I think we could implement the workaround. I will need to do more investigation regarding this issue and where to integrate into the Studio.

Thanks for the link, I will add to our bug database and look to implement this change in a future release.

Kind regards

Steve Upton
0 x


Who is online

Users browsing this forum: No registered users and 0 guests