Java 11.0.2 upgrade in Verj.io 5.5.0

Post any questions regarding Installing or Upgrading Ebase, including problems starting up the Ebase Xi Server or Designer

Moderators: Ian, Dave, jcoulson, Jon, Wai

neilnewman
Ebase User
Posts: 151
Joined: Fri Dec 20, 2013 1:29 pm
Location: Dartford Borough Council
Contact:

Java 11.0.2 upgrade in Verj.io 5.5.0

#1

Postby neilnewman » Fri Mar 15, 2019 2:12 pm

I have just upgraded one of our systems to 5.5.0 and thought I would also upgrade to Java 11.0.2, all appears to be working (I think), but I have a couple of errors in the client cmd window, are these expected or have I got something wrong:

Thanks
Neil

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.sun.xml.bind.v2.runtime.reflect.opt.In
jector$1 (file:/D:/Ebase/capita-ebase-live/UfsClient/lib/jaxb-impl-2.2.1.1.jar)
to method java.lang.ClassLoader.defineClass(java.lang.String,byte[],int,int)
WARNING: Please consider reporting this to the maintainers of com.sun.xml.bind.v
2.runtime.reflect.opt.Injector$1
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflect
ive access operations
WARNING: All illegal access operations will be denied in a future release
[ERROR]: Cannot locate JRE jar in D:\Ebase\capita-ebase-live\UfsClient\jre
Mar 15, 2019 2:07:22 PM java.net.CookieManager put
SEVERE: Invalid cookie for javascripts://vault.verj.io/ebase/experience.eb?desig
nerToken=67ff25143935f07d84dead6d509cb4da65bfdecc&suppressWelcome=false&ebDesign
er=true&ebd=0&ebp=30&ebz=1_1552658839644: _hjCookieTest
0 x

Ben
Ebase Developer
Ebase Developer
Posts: 8
Joined: Tue Sep 18, 2007 3:21 pm

Re: Java 11.0.2 upgrade in Verj.io 5.5.0

#2

Postby Ben » Fri Mar 15, 2019 3:38 pm

Hi Neil,

All of these logs are OK to live with. They are either expected or reporting errors where there are none. I'll try to tidy up the last two, but I think we'll have to live with the warnings for a while.

regards
Ben



The first bunch of WARNINGs are triggered at the same time. It's saying that something in the jaxb-impl is using java reflection to access something in ClassLoader. From Java9, we are being encouraged to stop using reflection to access internal Java functionality. There are loads of these and we will slowly remove them. jaxb-impl is made by Oracle, so they'll hopefully sort out that one!

The ERROR, about locating JRE, is just a bad error message. It's trying to find a java jar to help with code completion in the script editor. It doesn't find anything in the java 8 location, reports the "ERROR", and then finds it in the java 11 location.

The SEVERE message about cookies is reporting a bad cookie from the verjio.io website. It really doesn't need to make so much fuss, because everything continues fine.
0 x

neilnewman
Ebase User
Posts: 151
Joined: Fri Dec 20, 2013 1:29 pm
Location: Dartford Borough Council
Contact:

Re: Java 11.0.2 upgrade in Verj.io 5.5.0

#3

Postby neilnewman » Fri Mar 15, 2019 3:49 pm

Thanks Ben,
I will move onto upgrading our live instance then.
0 x


Who is online

Users browsing this forum: No registered users and 1 guest