SOAP repeating field from table

View and download documents on various topics e.g. Configuring Ebase Xi under different environmental setups

Moderators: Ian, Dave, jcoulson, Jon, Wai

dafydd
Ebase User
Posts: 1
Joined: Wed Mar 21, 2018 3:33 pm

SOAP repeating field from table

#1

Postby dafydd » Mon Mar 26, 2018 10:16 am

ebase Version 5.2.0 Build 20160817

I'm trying to send information from an ebase table into a SOAP webservice, I've got the form table set with the repeating field resource in the web service but nothing appears in the web service send request when looking at the debug log

When testing from the web service test screen with the following code inserted the data is populated.
<ser:AdditionalFields>
<ser:AdditionalFieldSend>
<ser:FieldLine>3</ser:FieldLine>
<ser:ValueType>7</ser:ValueType>
<ser:DataValue>English</ser:DataValue>
</ser:AdditionalFieldSend>
<ser:AdditionalFieldSend>
<ser:FieldLine>4</ser:FieldLine>
<ser:ValueType>7</ser:ValueType>
<ser:DataValue>English</ser:DataValue>
</ser:AdditionalFieldSend>
</ser:AdditionalFields>

It looks like the web service is working ok but the form/resource is not sending the data from the table? Are you aware of any issues of this kind?
0 x

Steve
Moderator
Moderator
Posts: 305
Joined: Fri Sep 07, 2007 3:44 pm
Location: Sandy, UK
Contact:

Re: SOAP repeating field from table

#2

Postby Steve » Wed Mar 28, 2018 3:20 pm

Hi,

There should not be any issues with this.

Are you calling updateTable() before you invoke the resource? This pushes the data form the Ebase Table into the resource?

so your script should looks something like this:

Code: Select all

//push data into the resource from the Ebase Table
tables.mySoapTable.updateTable();
resources.mySoapCall.call();
If you are doing this, then please export your form and resource and script and I will take a look and email it to support@ebasetech.com

Kind regards

Steve
0 x


Who is online

Users browsing this forum: No registered users and 1 guest