Issue calling web services

Post any questions regarding Installing or Upgrading Ebase, including problems starting up the Ebase Xi Server or Designer

Moderators: Ian, Dave, jcoulson, Jon, Wai

neilnewman
Ebase User
Posts: 162
Joined: Fri Dec 20, 2013 1:29 pm
Location: Dartford Borough Council
Contact:

Issue calling web services

#1

Postby neilnewman » Tue Sep 19, 2017 9:07 am

Our installation is running Ebase 5.2.0 Build 20160817 with Apache Tomcat 8.2.20 and Java 1.8.0.141.
When we attempt to call a web service we get the following message:

"Error calling webservice : com.ebasetech.ws.core.cxf.client.CXFExceptionWrapper: Could not invoke service. java.lang.NullPointerException"

I assume we are missing a jar file of some kind from the installation.
Anyone got any pointers please.
0 x

Jon
Moderator
Moderator
Posts: 1278
Joined: Wed Sep 12, 2007 12:49 pm

#2

Postby Jon » Tue Sep 19, 2017 9:25 am

There should be a Java stack trace in one of your log files in tomcat/logs.
0 x

neilnewman
Ebase User
Posts: 162
Joined: Fri Dec 20, 2013 1:29 pm
Location: Dartford Borough Council
Contact:

#3

Postby neilnewman » Tue Sep 19, 2017 9:44 am

I have shutdown Tomcat removed the log files and restarted Tomcat and re-tried the Web Connector service which has the "Debug" field ticked, this produced the same onscreen error, but I cannot see anything in any of my log files.
The only file containing anything of interest is the catalina.log file:


19-Sep-2017 11:16:06.791 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Server version: Apache Tomcat/8.5.20
19-Sep-2017 11:16:06.792 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Server built: Aug 2 2017 21:35:49 UTC
19-Sep-2017 11:16:06.792 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Server number: 8.5.20.0
19-Sep-2017 11:16:06.792 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log OS Name: Windows Server 2012 R2
19-Sep-2017 11:16:06.792 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log OS Version: 6.3
19-Sep-2017 11:16:06.792 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Architecture: amd64
19-Sep-2017 11:16:06.792 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Java Home: D:\Ebase\dbc-ebase-test\jre
19-Sep-2017 11:16:06.793 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log JVM Version: 1.8.0_141-b15
19-Sep-2017 11:16:06.793 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log JVM Vendor: Oracle Corporation
19-Sep-2017 11:16:06.793 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log CATALINA_BASE: D:\Ebase\dbc-ebase-test\UfsServer\tomcat
19-Sep-2017 11:16:06.793 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log CATALINA_HOME: D:\Ebase\dbc-ebase-test\UfsServer\tomcat
19-Sep-2017 11:16:06.793 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Command line argument: -Dcatalina.home=D:\Ebase\dbc-ebase-test\UfsServer\tomcat
19-Sep-2017 11:16:06.793 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Command line argument: -Dcatalina.base=D:\Ebase\dbc-ebase-test\UfsServer\tomcat
19-Sep-2017 11:16:06.793 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Command line argument: -Djava.endorsed.dirs=D:\Ebase\dbc-ebase-test\UfsServer\tomcat\endorsed
19-Sep-2017 11:16:06.793 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Command line argument: -Djava.io.tmpdir=D:\Ebase\dbc-ebase-test\UfsServer\tomcat\temp
19-Sep-2017 11:16:06.793 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Command line argument: -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
19-Sep-2017 11:16:06.793 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Command line argument: -Djava.util.logging.config.file=D:\Ebase\dbc-ebase-test\UfsServer\tomcat\conf\logging.properties
19-Sep-2017 11:16:06.793 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Command line argument: -Xss2048k
19-Sep-2017 11:16:06.794 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Command line argument: -XX:MaxPermSize=256m
19-Sep-2017 11:16:06.794 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Command line argument: -Djavax.net.ssl.trustStore=D:\Ebase\dbc-ebase-test\https\cacerts
19-Sep-2017 11:16:06.794 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Command line argument: -Dsun.security.ssl.allowUnsafeRenegotiation=true
19-Sep-2017 11:16:06.794 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Command line argument: exit
19-Sep-2017 11:16:06.794 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Command line argument: -Xms1024m
19-Sep-2017 11:16:06.794 INFO [main] org.apache.catalina.startup.VersionLoggerListener.log Command line argument: -Xmx2048m
19-Sep-2017 11:16:06.794 INFO [main] org.apache.catalina.core.AprLifecycleListener.lifecycleEvent Loaded APR based Apache Tomcat Native library [1.2.12] using APR version [1.5.2].
19-Sep-2017 11:16:06.794 INFO [main] org.apache.catalina.core.AprLifecycleListener.lifecycleEvent APR capabilities: IPv6 [true], sendfile [true], accept filters [false], random [true].
19-Sep-2017 11:16:06.794 INFO [main] org.apache.catalina.core.AprLifecycleListener.lifecycleEvent APR/OpenSSL configuration: useAprConnector [false], useOpenSSL [true]
19-Sep-2017 11:16:07.738 INFO [main] org.apache.catalina.core.AprLifecycleListener.initializeSSL OpenSSL successfully initialized [OpenSSL 1.0.2k 26 Jan 2017]
19-Sep-2017 11:16:08.744 INFO [main] org.apache.coyote.AbstractProtocol.init Initializing ProtocolHandler ["http-nio-3040"]
19-Sep-2017 11:16:08.948 INFO [main] org.apache.tomcat.util.net.NioSelectorPool.getSharedSelector Using a shared selector for servlet write/read
19-Sep-2017 11:16:08.951 INFO [main] org.apache.coyote.AbstractProtocol.init Initializing ProtocolHandler ["ajp-nio-8449"]
19-Sep-2017 11:16:08.956 INFO [main] org.apache.tomcat.util.net.NioSelectorPool.getSharedSelector Using a shared selector for servlet write/read
19-Sep-2017 11:16:08.957 INFO [main] org.apache.catalina.startup.Catalina.load Initialization processed in 2819 ms
19-Sep-2017 11:16:08.990 INFO [main] org.apache.catalina.core.StandardService.startInternal Starting service [Catalina]
19-Sep-2017 11:16:08.990 INFO [main] org.apache.catalina.core.StandardEngine.startInternal Starting Servlet Engine: Apache Tomcat/8.5.20
19-Sep-2017 11:16:09.005 INFO [localhost-startStop-1] org.apache.catalina.startup.HostConfig.deployDescriptor Deploying configuration descriptor [D:\Ebase\dbc-ebase-test\UfsServer\tomcat\conf\Catalina\localhost\ufs.xml]
19-Sep-2017 11:16:16.843 INFO [localhost-startStop-1] org.apache.jasper.servlet.TldScanner.scanJars At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.
19-Sep-2017 11:16:29.027 INFO [localhost-startStop-1] org.apache.catalina.startup.HostConfig.deployDescriptor Deployment of configuration descriptor [D:\Ebase\dbc-ebase-test\UfsServer\tomcat\conf\Catalina\localhost\ufs.xml] has finished in [20,023] ms
19-Sep-2017 11:16:29.187 INFO [localhost-startStop-1] org.apache.catalina.startup.HostConfig.deployWAR Deploying web application archive [D:\Ebase\dbc-ebase-test\UfsServer\tomcat\webapps\ebaseWS.war]
19-Sep-2017 11:16:31.139 INFO [localhost-startStop-1] org.apache.jasper.servlet.TldScanner.scanJars At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.
19-Sep-2017 11:16:31.142 INFO [localhost-startStop-1] org.apache.catalina.startup.HostConfig.deployWAR Deployment of web application archive [D:\Ebase\dbc-ebase-test\UfsServer\tomcat\webapps\ebaseWS.war] has finished in [1,955] ms
19-Sep-2017 11:16:31.188 INFO [localhost-startStop-1] org.apache.catalina.startup.HostConfig.deployDirectory Deploying web application directory [D:\Ebase\dbc-ebase-test\UfsServer\tomcat\webapps\ROOT]
19-Sep-2017 11:16:33.412 INFO [localhost-startStop-1] org.apache.jasper.servlet.TldScanner.scanJars At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.
19-Sep-2017 11:16:33.415 INFO [localhost-startStop-1] org.apache.catalina.startup.HostConfig.deployDirectory Deployment of web application directory [D:\Ebase\dbc-ebase-test\UfsServer\tomcat\webapps\ROOT] has finished in [2,227] ms
19-Sep-2017 11:16:33.426 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["http-nio-3040"]
19-Sep-2017 11:16:33.436 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["ajp-nio-8449"]
19-Sep-2017 11:16:33.439 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in 24479 ms
0 x

neilnewman
Ebase User
Posts: 162
Joined: Fri Dec 20, 2013 1:29 pm
Location: Dartford Borough Council
Contact:

#4

Postby neilnewman » Tue Sep 19, 2017 11:14 am

I have just installed an out of the box copy of Ebase 5.2.0 onto my PC and imported the Web service in question.
This fails to run with the same error:

Error calling webservice : com.ebasetech.ws.core.cxf.client.CXFExceptionWrapper: Could not invoke service. java.lang.NullPointerException
0 x

Steve
Moderator
Moderator
Posts: 328
Joined: Fri Sep 07, 2007 3:44 pm
Location: Sandy, UK
Contact:

#5

Postby Steve » Tue Sep 19, 2017 11:31 am

Hi Neil,

Can you send me the web service to:

support@ebasetech.com

I will take a look.

Kind regards

Steve Upton
0 x

neilnewman
Ebase User
Posts: 162
Joined: Fri Dec 20, 2013 1:29 pm
Location: Dartford Borough Council
Contact:

#6

Postby neilnewman » Tue Sep 19, 2017 12:05 pm

Please ignore the post, I have since found out that the web service we were connecting to had been upgraded and moved to another server.

Now adjusted the web service and all is now working
0 x

Steve
Moderator
Moderator
Posts: 328
Joined: Fri Sep 07, 2007 3:44 pm
Location: Sandy, UK
Contact:

#7

Postby Steve » Tue Sep 19, 2017 1:09 pm

Thanks Neil,

Could you zip up the log files and send them to me anyway, so I can see why this call was throwing that error.

Kind regards

Steve
0 x

neilnewman
Ebase User
Posts: 162
Joined: Fri Dec 20, 2013 1:29 pm
Location: Dartford Borough Council
Contact:

#8

Postby neilnewman » Tue Sep 19, 2017 2:14 pm

Hi Steve,
I have rerun the test and zipped up the log files and emailed them to you.

Thanks
Neil
0 x

neilnewman
Ebase User
Posts: 162
Joined: Fri Dec 20, 2013 1:29 pm
Location: Dartford Borough Council
Contact:

#9

Postby neilnewman » Wed Sep 20, 2017 10:00 am

Hi Steve,
I have been doing some more testing and found that the connection is very intermittent and fails most of the time.
I have installed SOAPUI onto my PC and the web service connection appears to work 100% of the time when tested using the SOAPUI tool.

If you need to connect onto our system in order to diagnose the issue, then please let me know, and I will give you the instructions.

The Ebase system is trying to communicate with our Idox Uniform system, I am not sure what the issue is but it only appears to be an issue from our Ebase installation.

Many thanks
Neil
0 x

Steve
Moderator
Moderator
Posts: 328
Joined: Fri Sep 07, 2007 3:44 pm
Location: Sandy, UK
Contact:

#10

Postby Steve » Thu Sep 28, 2017 8:06 am

After doing some research I found an error in the Session Cookie code.

If you have the session cookie checkbox checked and run the test dialog, it throws a NullPointerException.

If you need the session cookie, then you need to run your test from within a form, otherwise you do lose any session cookie data between calls, so this is not really an applicable test.

Steve
0 x

neilnewman
Ebase User
Posts: 162
Joined: Fri Dec 20, 2013 1:29 pm
Location: Dartford Borough Council
Contact:

#11

Postby neilnewman » Thu Sep 28, 2017 12:39 pm

Thanks Steve,
Yes we found that the form worked fine with the maintain cookie box ticked, it was just the testing feature that had the issue.

Many thanks for the advise.

Kind regards
Neil
0 x


Who is online

Users browsing this forum: No registered users and 2 guests